Nova sekureca versio

Uzantoj de versio 4.7.1 kaj pli fruaj versioj de WordPress estas konsilitaj ĝisdatigi retejojn al versio 4.7.2.
Pli fruaj versioj havas 3 sekurecajn problemojn:
1. la uzinterfaco por asigno de taksonomioj en Presi Tion Ĉi aperas al uzantoj sen rajtoj uzi ĝin.
2. WP_Query povas ricevi enmeton de fi-kodo per SQL dum transmeto de nesekuraj datumoj.
3. trans-reteja skripto povas esti enmetita en la tabelon de afiŝo-listoj.

Se via WordPress-ejo ne subtenas aŭtomatajn ĝisdatigojn, elŝutu WordPress 4.7.2 aŭ iru al Ĝisdatigoj en via administra panelo.

BuddyPress

Socia retejo BuddyPress por WordPress ricevis malnetan enesperantigon.
Por helpi provlegi, iru al https://translate.wordpress.org/projects/wp-plugins/buddypress/stable/eo/default kaj faru proponojn.

Post instalo, vi vidos bonvenan ekranon. Post rigardo al la bonvena ekrano, iru al Agordo -> BuddyPress por (mal)ŝalti eblojn de uzantoj, vidi kaj eble ŝanĝi la paĝojn de BuddyPress, ktp.
Multaj agordoj kaj funkcioj estas en aliaj lokoj, tamen. Vi devos rigardi al viaj menueroj. Ekzemple, kreo de novaj kampoj por aperi en profiloj estas en la administra menuo Uzantoj -> Profilaj kampoj.

NOTO: se vi volas, ke grupoj havu forumojn, vi devas instali bbPress. BuddyPress uzas la kromprogramon bbPress por forumoj.

ALIA NOTO: se vi jam uzas BuddyPress, sed en la angla lingvo, kelkaj linioj ne aperos en Esperanto, escepte se vi ree instalos BuddyPress. Kreu sekurkopion de la datumbazo antaŭ forigo de BuddyPress, por ne perdi la ekzistantajn datumojn.

Por helpi kompreni pri la komenca starigo, mi skribis kelkajn paŝojn: http://cindymckee.com/testejo/buddypress-instrukcioj

bbPress

La plej populara kromprogramo por forumo de WordPress, bbPress estas enesperantigita. Ĝi estas rapida kaj simpla forumo / forumaro. Aliaj programistoj kreis multajn etendaĵojn por enkonduki pliajn utilaĵojn al bbPress.
Post instalo kaj aktivigo de bbPress, vi tuj ricevos ekranon en kiu vi rajtos elekti nomojn de la apartaj paĝoj de la forum(ar)o kaj aliajn opciojn.
Post la konservo de viaj elektoj, rigardu al la maldekstra menuo en la administra panelo kaj alklaku al “Forumoj -> Nova forumo”. Tipo ‘Kategorio’ kutime servas kiel ujo (aŭ ‘patro’) por pluraj forumoj.
Dum vi laboras en la ekranoj, ne forgesu alklaki al Helpo en ĉiu ekrano.
Roloj de uzantoj, laŭ ordo de povoj: Klavmajstro (administranto), Kontrolanto, Partoprenanto, Spektanto kaj Baritaj uzantoj.

Komunuma kalendaro

Event-kalendaro por komunumoj (All-in-One Event Calendar) estas malnete tradukita. Senpage, uzantoj povas krei eventojn kaj vizitantoj rajtas ‘aboni’ la kalendaron de eventoj per enmeto de la fluo en plurajn aliajn kalendarajn tipojn. Vidu butonon “Aboni” ĉe la test-kalendaro.
Bonvole alklaku al evento tie por vidi la aranĝon de event-paĝo.

Ankaŭ aliaj retej-administrantoj povas ricevi aŭtomatan listigon de la baldaŭaj eventoj de tiu kalendaro, en siaj propraj retejoj. Vidu liston el la test-kalendaro. Bonvole alklaku al evento por vidi la ŝprucfenestron.
Filtrado de eventoj eblas, laŭ kategorio aŭ etikedo.

Ŝajnas ke uzantoj rajtas vendi biletojn al eventoj kun pagoj per PayPal. Paga etendaĵo etendas tiun eblon.
Ankaŭ paga etendaĵo permesas aŭtomatan enigon el aliaj kalendaroj en propran kalendaron (per fluo el dosiertipoj .ics kaj .csv [kosto de tiu etendaĵo: $30 USD jare]).

Permeso al uzantoj enmeti eventojn estas paga eblo, tamen uzanto povas enmeti formularon kreitan de alia kromprogramo – denove, vidu la ekzemplon ĉe la test-kalendaro, danke al Formularoj de Ninja(Ninĵoj).

Notu, ke tiu ĉi kromprogramo ne ricevas ĝisdatigon ekde la WordPress-versio 4.7, sed funkcias bone en versio 4.7 de la testejo.
Aldone, ĝi havas kelkajn netradukeblajn liniojn.
Sed ĝi estas profesiaspekta kaj donas multajn senpagajn funkciojn.

TinyMCE Altnivele

Antaŭ minutoj, unu el la plej popularaj kromprogramoj por WordPress, TinyMCE Altnivele (TinyMCE Advanced), estis enesperantigita. TinyMCE estas la tekstoredaktilo de WordPress kaj la kromprogramo etendas la ilobretojn kaj funkciojn de tiu kutima TinyMCE-redaktilo. Multaj uzantoj volas elekton de tiparoj. Tiu ĉi kromprogramo donas elekton de kelkaj tiparoj. La kromprogramo ankaŭ ebligas rektan kreon de tabeloj, alian deziron de kelkaj uzantoj.
Vidu ekrankopion de la ilobretoj post instalo kaj aktivigo de TinyMCE Altnivele kaj alklaku por pli granda rigardo:

tinyMCE-altnivele-ilobretoj
Montro de la nova, etendita ilobretaro en la tekstredaktilo, kun miaj aldonoj (per la agordoj) de miensimboloj, paĝosalto kaj nerompebla spaceto sur la plej suba ilobreto.

Vi volos iri al Agordo -> TinyMCE Advanced (aŭ TinyMCE Altnivele) por aldoni viajn elektojn de neuzitaj funkcioj al pliaj ilobretoj kaj aliajn opciojn.

Agordoj de TinyMCE Altnivele.


Notu, kiel ĉiam, ke temas pri kromprogramo por la sendependa WordPress, ne la gastigo-reto wordpress.com.